Get in touch
Back
Resolved

Some services are down

Started 15 Jul at 09:27pm UTC.

Staging Testnet Honoroll API (api.staging.testnet.honoroll.io)
Created

Staging Testnet Honoroll API (api.staging.testnet.honoroll.io) went down.

Posted 15 Jul at 09:27pm UTC.